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CUB.X Presentation

All the data used in the examples are totally fictitious. Some of the screens are
designed solely to enhance explanation or document composition and so may
be different from reality.

The CUB.X program for Windows is a tool for exploiting statistical multi-
dimensional tables.

CUB.X is the property of  Eurostat. This software can be used for your needs,
free of charge, but cannot be resold. It may not be used for commercial gain or
distributed without prior authorisation by Eurostat.

Information in this document and the content of all CUB.X files are subject to
change without notice and do not represent a commitment on the part of
Eurostat.

Information in this document and the content of all CUB.X files are subject to
change without notice and do not represent a commitment on the part of
Eurostat. We shall not be liable for editorial omissions made herein ; nor for
incidental or consequential damages resulting from the misuse of the CUB.X
program.

COPYRIGHT ©

This manual may not, in whole or in part, be photocopied, reproduced,
transcribed, translated, or transmitted in whatsoever form without the written
consent of Eurostat, except for copies retained by the user of CUB.X for
personal archival purposes.

COPYRIGHT © 1996 Eurostat. All rights reserved.

A full Cub.X manual is available on request.
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Conventions
8 Ø means : select using the mouse.

7 Ø means : select using the keys.

ÿ Ø means : use MS-Windows features

REMEMBER ! Under the MS-Windows environment :

Ø 8 click to maximize a window

 Ø   8 click to reduce a window (put the window in background)

Ø  8 click to reduce or restore a window

To exit any program running under MS-Windows :

7 Ø ALT+F4 -or-

8 Ø Double-click the System Menu (  ) in the upper left corner of 
the active window.

  Ø means : use the arrow keys (to scroll, etc.).

(if you are using the numeric keypad,
make sure NUM LOCK is off before
using it).
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Installation procedure (CD-ROM)
Before the installation : if you have an older version of CUB.X, delete the file
eurostat.ini  located in windows directory, the old version of CUB.X and the
New Cronos directory.

See also the readme.txt file in the CD-ROM root.

If MS-Windows is not already running, type Win at the DOS prompt.

Insert the New Cronos CD-ROM in your CD-ROM drive.

Setup.exe This procedure covers the basics for setting up Cub.X

8 Ø From the File menu, choose Run 7 Ø (ALT, F, R)
or Start Run in Windows95. 

Type : d:/setup (should your CD-ROM drive name be d:). When the program
asks you for target directories :

1. for the “New Cronos Data”, click OK to accept c:\newcron directory by
default (or type any other directory),

2. for the “New Cronos Software”, click OK to accept c:\refer.win directory by
default (or type any other directory).

The installation procedure creates the ”New Cronos Software” and the “New
Cronos Products” program groups.

The icons are the following :
 

 for the New Cronos Products
 
and

  
 for the program.
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Working with Cub.X

If Windows is not already running, at the system prompt, type win and then
press Enter.

In the Program Manager, double-click the “New Cronos Software”
group icon or the group icon that contains Cub.X

Starting CUB.X To launch Cub.X

8 Ø Double-click the CUB.X Browse icon 

 
-or-

7 Ø Select the CUB.X Browse icon using the arrow keys,
then press Enter

Exit from CUB.X To quit Cub.X

8 Ø From the File menu, choose Exit 7 Ø (ALT, F, X)
-or-

ÿ Ø Use the "exit" feature of MS-Windows
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The data file
Opening a data file To open an existing data file

File extensions  : 
filename.dft and 
filename.cbx

8 Ø From the File menu, choose Open 7 Ø  (ALT, F, O)

The following dialog box appears :

A : type or select
the file you want to
open.

B : select a new
drive, if necessary.

C : select a new
directory, if neces-
sary.

8 Ø
Choose the OK button.

See also  “Many views, one datafile”  (Working with views) on page 18-19.

Closing a file To open another file without 
quitting Cub.X

8 Ø From the File menu, choose Close. 7 Ø (ALT, F, C)

Then : open a data file as above.

Information on the datafile To open an additional 
information file
File extension : filename.hlp

8 Ø From the "Information and Help" menu,7 Ø  (ALT, I, I)
 choose Information on the table

Warning ! Data files may not have this additional information.

Note : when you open a data file, an "Information and Help" window may open
automatically, and hide a part of the .DFT window : it gives you additional
information on the table, the origin of values, dimensions.... should your table
has an additional information file.
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The index file
An index is a file that organizes your data and allows you quicker access to
them. If your tables have a lot of data, it is necessary to use an index with the
table.

If you don't really know how to work with an index,

ð do not delete the first index you receive, and

ð do not activate the command confirm index in the
Options menu.

CUB.X will automatically read the index when you open the
data file.

If you decide not to use the index for a particular reason, you can activate an
option that will ask you if you want to use the index, each time you open a table.

Confirming an index To use an index
File extension : filename.IDX

8 Ø Before opening the file *.DFT, click the Options menu and look at
Confirm index

If the command is checked (ü), the index confirmation is active. So, the index is
NOT automatically used : you will have to confirm its use. A confirmation
message will appear.

If the command is not checked , it means that the index confirmation is not
active. So, the index will be used without notice.
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Consultation of a data file :
screen description

Cub.X is organised like a page of a spreadsheet ; it allows data to be viewed,
selected and exported. The window shows only a part of the page that may
contain more rows and columns than can be displayed on the screen.

Complete name of the current file X axis, one of the dimensions
Number of cells Y axis, one of the dimensions
Data presentation Horizontal scroll bar

Dimension blocks

Current file name
Drive, directories and file names are between 2 square brackets.

Number of  cells
The first number (2304/...) is the number of selected cells with  ; the
second (.../2304) is the number of all the cells defined in the file.

Data presentation
The intersection of the X and Y axes, and also the selected positions in
each other dimension block (set of positions - see page 9).

X axis
Horizontal axis. A value of the X axis defines a column.

Y axis
Vertical axis. A value of the Y axis defines a row.

Horizontal (vertical) scroll bar
Appears when the window size doesn't allow the whole table to be
displayed.

Dimension blocks



UNAVOIDABLE PARAGRAPH IN THE HEADER : HEIGHT 4 POINTS

9

Axis (X or Y) Labels

Indicates that the dimension is “Removes” all the dimension
used as X or Y axis. labels. To display all the 

labels, use the command
Options/Labels.

Information Select / Unselect

positions
Gives you more information about Allows you to select or
the dimension and its positions. unselect positions of the

dimension. Useful for
exporting a subset of the
data.

Go forward Go back

Go to the next position(s) Go to the previous position(s)
of the dimension. of the dimension.

Title of the dimension  

Name of the dimension. This name corresponds to the
associated dictionary (eeccountry.dic, for instance).

Origin of the dimension

This button allows you to select directly any position
you want to see. By clicking this button, the list of all
the positions appears. Click on one of them to select it.

Label of the origin

When CUB.X finds the associated dictionary of a data
file, it puts the labels in this box. If you don't see the
entire label, click on it : the label will appear in a label
box.
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Displaying data

Rotation of axes To invert the two main axes X & Y

It is useful to be able to rotate axes to see better some set of values. In the
following figure, the arrow shows you where you have to click to swap the two
axes.

Changing axes To replace one dimension by another as the 
X or Y axis to see easily all the corresponding 
values to each position

This command allows you to have only one file with one multi-dimensional table,
but many views of the data.

Three ways are provided to do this very important manipulation :

• drag and drop a dimension title toward an axis.
• drag and drop a dimension block title towards another one.
• use keyboard shortkeys to change quickly the place of each dimension.
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First method : ÿ8 Drag and drop a dimension title toward an axis

Move cursor to the title of the dimension block. Click and hold down the left
button, drag towards an axis, and drop (by releasing the mouse button).

Note : this option is applies only to dimensions other than X and Y.

Second method :  ÿ8 Drag and drop a dimension block title 
toward another one

In this example, product becomes the new X axis, and time will take the previous
place of product. The order of the other dimensions is reorganised.

Third method : 7 Ø Shortkeys to change quickly each 
dimension place

7 Ø CTRL + R to shift the 7 Ø CTRL + L to shift the 
dimension blocks to the dimension blocks to the 
right left.
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Charting with CUB.X To create a chart relative to the 
displayed  data

7 Ø Press CTRL + G

First, you have to decide what you want to present on the chart.

— The X axis of the table will be the X axis of the chart, in the example
below the countries.

— The selected position of the Y dimension will define the Y axis. In the
example below, the position mushroom will be the dimension product.

— The current line of the table (the line where the cursor is) will be
represented on the chart.

Note : Cub.X is not designed for charting : this is a rough and ready facility for
providing a graphical view of the selected data. Making more complex charts,
data manipulation and calculation, is left to your preferred software. (See
“Export manipulation” page 23).

Ø Click this button to reverse the axes order on the chart sheet
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Changing the alignment To change the alignment of all the 
cells. Only for the values, not for the 
labels.

8 Ø From the Options menu, choose Justify. 7 Ø (ALT, O, J)

You can chose between 3 options : Left , Center or Right Justify. The alignment
you choose will be kept for the next session of CUB.X whichever file you open.

Displaying a grid To choose the aspect of the table

8 Ø From the Options menu, choose Table. 7 Ø (ALT, O, T)

You can chose between 3 options. The option that you choose will be kept for
the next session of CUB.X whichever file you open.

Grid Panel None

Displaying all the labels Display the labels associated with 
each position of all the dimensions

To activate all the labels for all the dimension :

8 Ø From the Options menu, check the 7 Ø (ALT, O, L)
command Labels

 Table with labels activated :

Table without
labels activated :
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 To activate or remove the labels of one dimension

8 Ø Click  to remove all the dimension labels.

The 
 
becomes .

8 Ø Click  to display again all the dimension labels.

The 
 
becomes .

You can selectively activate the labels of only some of the dimensions.

If you want few labels, it is better to remove the check mark of the menu
Options/ Labels , whereas if you want a lot of labels, it is better to check this
option.

To see the entire label When labels are too large to be read

8 Ø Point to the label on the dimension block, click and hold down the 
left button of the mouse.

-or-

8 Ø Point to the label in the table, click and hold down the left button of 
the mouse.

Ø Release the left button and the label disappears.

Example :

Decimals To choose the number of decimals

8 Ø From the Options menu, choose 7 Ø (ALT, O, D)
Decimals
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Columns/Rows To size all columns and/or rows

8 Ø From the Options menu, choose 7 Ø (ALT, O, C)
Columns/Rows

Ø Use the mouse to select a size in one of the dialog boxes

OR Ø Use the mouse to size directly one row and/or one column :

Restore native order Used to reset the original presentation 
after making changes in the display of 
the table

8 Ø From the Presentation menu, choose 7 Ø (ALT, P, N)
Restore native order

Reset ranges To cancel everything done with 

8 Ø From the Presentation menu, choose 7 Ø (ALT, P, E)
Reset ranges

Refresh screen To rebuild a disturbed display

8 Ø From the Presentation menu, choose 7 Ø (ALT, P, R)
Refresh screen

Change of language 

8 Ø From the Options menu, choose 7 Ø (ALT, O, L,è , 
Language ê or é)

Ø Select one Language Press Enter
Refer also to “Dictionary manipulation”.
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Selecting or unselecting position(s) of a dimension
To select the positions you want to be shown on the screen

8 Ø Click on the button of the corresponding dimension block. 
This dialog box appears :

 �   Ø This box displays all the
selected positions of the
dimension (the positions
to be  shown on the
screen).

�   Ø This box displays all the
unselected positions of
the dimension (the
positions not to be seen
on the screen).

The button � allows you to move the highlighted positions from box �
to box � :  these positions will be unselected and not shown.

The button � allows you to move the highlighted positions from box �
to box � : these positions will be (re-)selected and shown.

By clicking one of the buttons � - or � -, a dialog box appears. In this
dialog box, you can enter an expression, called a regular expression,
that allows you to activate  positions (highlighted positions) to be
selected in box �, - or in box � respectively -.

By clicking one of the buttons � - or � -, a dialog box appears which
allows you to deactivate some highlighted positions, from box �, - or
from box � respectively -. The mechanism of regular expressions is
used (cancel some selections made in box �, - or in box �-).

This button validates all your  Cancel any previous
changes. operations in this 

dialog box.

Notes :

ð These selection(s) do not imply that your values will be deleted from the
table.

ð You will find a detailed explanation of regular expressions and their use
in the Memo on page 28.
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Example

Initially, all the dimensions values can be seen. Suppose you may want to see
only some of the position.

To unselect some positions :

1 Click   in the dimension block to unselect some positions.

2 In the selected positions box �, click all the products you don't want to
see, to unselect them

3 Click : the highlighted products are transferred automatically to the

unselected positions box.

4 Click OK

The result is the same table with only the positions that interest you.

To re-select those positions, you just have to do the same thing in box � and

click .
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Many views, one datafile

Introduction
A view allows you to have a certain way of looking at your data, specifying a
presentation and selection. It is similar to saving your file with another name ;
but saving a view (.CBX) is much more interesting than saving a file (.DFT).

To open a view File extension : filename .CBX

8 Ø From the File menu, choose Open 7 Ø (ALT, F, O)

Select the view that you want to open (a name followed by the extension .CBX).
The view opens the corresponding data file with the data represented as you
choose.

To save a view To save or create a presentation 
that you would like to work with 
(to export, to read...)
File extension: filename .CBX

To store a view on your hard disk :

8 Ø From the Presentation menu, 7 Ø (ALT, P, V, S)
choose View.
Then choose the option Save a view

G Warning ! Make sure that the file keeps the extension .CBX.
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Working with views

You have two ways to work with an existing view of a file :

ð You open directly the view (.CBX), instead of opening the data file (.DFT).

ð You open the data file (.DFT), and then, when you need it, you load the
attached view.

To load a view To load an existing view attached 
to the opened .DFT datafile.
File extension : filename .CBX

8 Ø From the Presentation menu, choose 7 Ø (ALT, P, V, L)
View.

Ø Then choose the option Load a view.

When you release the mouse
button, CUB.X allows you to save
current changes in a new view :

If you want to save it, follow the instructions of the paragraph "To save a view".

A dialog box appears, asking you to choose the view (.CBX) that you want to
load in the file list box, for example, PRODUCT.CBX.

You are in the same data file, but with another "View".

You can load many views in a CUB.X session (one at a time).

Note : you can't load a
view that is not
attached to the open
data file because a
view is linked to a
unique data file. In
case of mismatch, you
get this message :
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Dictionary manipulation

Introduction

When you see the dimensions with their corresponding labels, it means that
CUB.X has found the dictionaries and associated them with each dimension. All
the following conditions have to be respected :

ð the associated files .DIC exist.

ð the dimension and the file .DIC have the same name. The file name is
limited to 8 characters. So, for example, for the dimension "eeccountry",
the corresponding dictionary will be "eeccount.dic".

ð CUB.X finds the dictionaries in the defined directory built automatically
from the dictionary root. If CUB.X doesn't find any dictionaries, you have
to indicate where they are stored. (See also page 22 : “Change dictionary
root”).

Checking dictionary

Dictionary and dimension To verify what each dimension 
uses as dictionary

8 Ø From the Dictionary menu, choose 7 Ø (ALT, D, I)
Dimension

This dialog box appears,
and you can verify each
dimension :

The storing of dictiona-ries
follows the same logical
structure as the data files.
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Path for labels in menu dictionary To see and verify all  
paths where Cub.X 
searches for the labels

8 Ø From the Dictionary menu, choose 7 Ø (ALT, D, E)
Search path for the labels

There are many paths, because there are a lot of possibilities to store these
files. CUB.X builds these paths from the root directory which is the basic
directory used to find .DIC file for each dimension ; (to build the root dictionary,
see the next page).

Example :

In this figure, you can see all the paths that CUB.X builds and where it searches
for the labels (the files .DIC) to associate them with each corresponding
dimension.

The chosen language is English ; in the path, you can see "en", because the
English dictionaries are in the directory "en".

In accordance with the selected language (Options/Language), CUB.X builds the
paths and can open the dictionary in the corresponding language.

For example, choose the language French. To check the new path, choose the
command Search path for labels from the menu Dictionary. The "en" from the
previous figure has become "fr".

Change of language 

Refer to “Displaying data”



22

Changing the dictionary root

8 Ø From the Dictionary menu, choose 7 Ø  (ALT, D, D)
Dictionary root.

Ø Choose the dictionary directory

The dictionary mechanism is activated from the directory root. This top directory
is the basic directory which is used to find the .DIC file for each dimension.

Example

� Choose the drive è � Go on the root    è � Choose the "top"
where Cub.X will of the drive directory of the
find the dictionaries. dictionaries

è è

When you are on the root of the drive, and see all the top directories of the drive,
select the top directory where the dictionaries are stored, but don't go further..

The screen shows you the directory used for the demo example, which possibly
doesn't correspond to the directory of your data files.

1 Click (only once) on the top dictionaries' directory, to select it.

2 Click OK

When you select the root directory, you must stay on the main directory without
going further because Cub.X builds the path automatically. If you should go
deeper in the tree structure, Cub.X will build an erroneous path.
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Export manipulation
G Important before exporting data

Exporting a lot of data can use up a lot of resources and risks freezing your PC
for a  very long time.

It is better and faster to export several two-dimensional tables
(the displayed XY table that interests you),

rather than a large multi-dimensional table.

Introduction
You use the Cub.X command Export to export data or to be able to read data in
different formats. Remember that whatever method you choose to export data,
only the selected data will be exported.

Two ways to export data to be used in another application are provided :

� Use the Windows’ Clipboard
� Use the Export facility

� ÿ Windows' Clipboard

Copy all the positions You want to export the displayed table 
(X and Y) with all its positions

8 Ø From the Edit menu, choose 7 Ø  (ALT, E, A)
Copy XY all

Copy selected positions Having unselected some positions 
in a presentation, you want to export 
the displayed table (X and Y) with only 
its selected positions

8 Ø From the Edit menu, choose the 7 Ø  (ALT, E, S)
command Copy XY selected
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� Export facility

Export multi-dimensional tables

To export XY To export the data displayed in a
two-dimensional table

8 Ø From the Options menu, see the command
XY export mode (otherwise All)

ð To export XY, the command must be checked.

Click the menu Export, and choose the target file format.

Type a new name for the target file.

To export all the possible combinations To export all the 
data

8 Ø From the Options menu, see the command
XY export mode (otherwise All)

ð To export all the data, the command must be NOT checked.

Click the menu Export, and choose the target file format.

Type a new name for the target file.

Note : if labels are not displayed, they will not be exported. Please see “Display
data”.

G Do not use reserved extensions like .XLS, .DOC, etc. It is better to make the
distinction between your exportation files and other applications files.
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Export formats

Export To choose the export format

8 Ø From the Export menu, 7 Ø  (ALT, X, ê or é )

Choose the export format you want to use : Table, Stream or Eurostat

Ø select again between 7 Ø  (è , ê or é )
the options provided Press Enter

Table : three different table formats are available.

DIF Data Interchange Format
Only for XY tables and accepted by most of the well-known
spreadsheets on the market.

EXCEL/TAB This option allows tables to be input to the EXCEL system. In
fact, this format is a "tab delimited" format, each cell being
enclosed by a double quotation mark <"> and separated with a
<tab>.

CSV Comma Separated Values
This format is the same as that of EXCEL except that the
delimiter between all fields is the comma <,>.
This kind of file is accepted, for instance, by the IMPROV
program.

Stream : three different kinds of file are available.

dBASE Accepted by dBASE software, this file has X + 1 fields with
X = number of dimensions
1 = value (last field).

Text This format is a text file with X + 1 columns
X = number of dimensions
1 = value (last column)
The separator between columns is a <space>.

CSV Same format as Text but using double quotation marks <"> to
enclose the contents of each column and a comma to separate
the columns.

Eurostat : the three formats (Fame, Osiris and Gesmes) are internal to
Eurostat.
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Help
Help Menu

CUB.X general Help To get help about Cub. X
File extension : filename.HLP

ÿ8 Ø From the Information and Help menu, 7 Ø  (ALT, I, H)
choose Help

Note : you are in a file managed by MS-Windows.

Help Interface

� to � : managed by Windows’ Help program.

� Opens automatically the specific help files.

� 2 buttons : to go to the previous page.

 to go to the next page.

� Jump to a cross-reference : if you click any term or phrase in colour and/or
underlined, you go straight to the specific part of the help file.

� Menu Bar  : managed by Windows’ Help program.
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This page is left intentionally blank for your notes...
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A memo on

Regular expressions (Unix)

Definition
A regular expression is a form used to specify and match strings. Regular
expressions use metacharacters (characters with a special meaning) and
nonmetacharacters (normal characters) as described below.

Introduction
The regular expression allows you to make some selections (to highlight them)
or to remove existing selections (to remove the highlighting) in order to Select or
Unselect them.

Using regular expressions replaces a series of the actions with the mouse in the

dialog box before clicking  or  to effect the transfer between the

selection and unselection boxes :

1 Click the select button 

2 In the "select - unselect positions" dialog box that appears, you click 

to highlight the item to select or unselect ; and you click  to remove

this highlight.

3 The following dialog box appears : you enter a regular expression that will
allow you to highlight (or to remove) the existing items.

A regular expression is a formalised way of describing a pattern which is then
used to search (in this case) the labels with a view to select or unselect
automatically.

For example, the regular expressions “N.*”  finds all the labels beginning with a
capital N (N followed by zero or more character of any sort - “.” meaning “any
single character” and “*” meaning the “.” occurring 0, 1, 2... times).
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Regular expression Metacharacters
To build a regular expression, you will need some of the following
metacharacters. Here are all the metacharacters (MC) supported in CUB.X.

MC Name Meaning MC Name Meaning

\ back-slash protection ( left
parenthesis

begin  of  expression

^ caret negation ) right
parenthesis

end of  expression

[ left square
bracket

begin of
class

* asterisk repeat 0,1,2,... times
the expression to its
left

] right
square
bracket

end of
class

? question mark repeat 0 or 1 time the
expression to its left

| pipe logical OR + plus repeat 1,2,3... times
the expression to its
left

. dot any single
character

Basic expression
A basic expression is one the following :

Nonmetacharacter
A If you write A, you will match the letter A

Quoted metacharacter
\* Matches one of the special metacharacters, in this case the

asterisk "*".
With "\", you cancel the effect of the metacharacter.

Character class
[ABC] Matches any one of the characters A B or C ;

[A-Z0-9] Matches one letter from A to Z (only in uppercase) or a digit.

Complemented character class
[^0-9] Matches any character except a digit.

Note : the ^ (negation) is active throughout the class.
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Operators
These operators combine regular expressions into longer ones :

Alternation A|B Matches A or B (uppercase)

(AB)|(CD) Matches AB or CD, but not A or B or C or D

Concatenation AB Matches uppercase A immediately followed by 
uppercase B

Closure A* Matches zero or more A's : {  ; A ; AA ; A...} 
(nothing or one or many uppercase A's)

Positive closure A+ Matches one or more A's : {A ; AA ; A...} (at least 
one uppercase A)

Conditional closure A? Matches zero or one A's : { ; A} (nothing or

one A)

Parentheses (r) Matches the same strings as the expression 'r' 
does ;  used to group many expressions, and also 

to give them priorities.

Use the labels for selection

To make selections with working with the regular

the labels of the dimension expression

8 Ø From the Options menu, look at the command +/- Labels.

When you use a regular expression, you can do the selection on the entire label
or on the abbreviation (“Belgium” or “be”) : in the selection boxes, you will
always have the abbreviations, so you must work with labels from memory, or
place the dialog box in a such way that you can see the labels from the
displayed table.

Ø To scan the entire set of labels with a regular expression, there must

be a check mark (ü).

For example : for the dimension “eeccountry”, you can write “Belg.*” to select
Belgium, only if you use the entire label.

No check mark means that you use the abbreviation “b.*”
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example 22

checking 20
dimension 20
introduction 20
labels 20, 21
path for labels 21

Dimension
axis 9
block (description) 9
go back button 9
go forward button 9
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information 9
labels 9
origin 9
selecting or unselecting 9, 16
shortkeys to move around 11
title 9

Display
Columns/Rows 15
grid 13
labels 13, 14
none 13
number of decimal 14
panels 13

Drag and drop methods. See Axes

Eurostat contacts 35
Exit

any program 3
from Cub.X 5

Export
all 24
before exporting data 23
clipboard (using Windows...) 23
Eurostat format 25
facility 24
formats 25
number of cells 23
stream format 25
table format 25
tables 24
XY 23, 24

File
.CBX extension 6, 18, 19
.DFT extension 6, 7, 18
.DIC extension 9, 20, 21, 22
.HLP extension 6, 26
.IDX extension 7
closing a file 6
informations on... 6
name of the current ... 8
opening a file 6
saving a file 18

Grid. See “Display”

Hardware 35
Help

Cub.X help interface 26
Horizontal scroll bar 8
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Index
confirming an index 7
file 7

Information on the datafile 6
Installation 4
Inverting order. See Axes

Labels
activating 14
dictionary 21
displaying 9, 13, 14
seeing the entire... 14

Labels with regular expression 30
Language (change the) 15

Number of cells 8, 23

Order (restoring native...) 15
Origin

label of the...) 9
of the dimension 9

Panels 13
Positions

copying 23
dialog box to select 16
Example of use 17
exporting 23
selecting or unselecting 16

Regular expression
basic expression 29
definition 28
introduction 28
memo 28
metacharacters 29
operators 30
selecting 16
selecting using labels 30
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Refreshing screen 15
Resetting ranges 15
Restoring native order 15
Root dictionary 22
Rotation. See Axes
Rows (sizing) 15

Save. See View
Screen description 8
Scroll bar 8
Selecting or unselecting position(s) 16
Setup. See Installation
System Requirements 35

Values (number of decimals) 14
Vertical scroll bar 8
View

introduction 18
loading 19
opening 18
saving 18
working with views 18, 19

Windows environment. See Conventions
Writing conventions. See Conventions

X axis definition 8

Y axis definition 8
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Eurostat contacts

Number of version of CUB.X : .....................................................

Contact :
"BUREAU DE DIFFUSION" of Eurostat ( +352 4301 32628

3 +352 4301 32594

For a technical problem call :

Eurostat New Cronos Support
Gérald TAYENNE ( +352 4301 37267

3 +352 4301 32594

Internet : tayenne@eurostat.cec.be

Minimum Hardware and System Requirements

w a 80486 PC based computer,

w at least 10 megabytes of hard disk space

w MS-DOS 5.0 and MS-Windows 3.1 (Enhanced mode) or later

w a CD-ROM drive ( x2 minimum).
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