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SESSION 1: Introduction to STATA

STATA is a Statistical Analysis System designed for research professionals.
The official website is http://www.stata.com/. It is an environment for
manipulating and analyzing data using statistical and graphical methods.
STATA is an integrated package — not a collection of separate modules.
However, some of the statistical features are contributed and differences in
language sometimes appear.

It can handle:

e Data Management
Basic statistics
Linear models
Graphics
ANOVA, etc.

Notation Conventions used throughout the course

1. These notes use either of the following conventions
Menu topic
Item
Item
or

Menu Item > Item > Item
to indicate that a sequence of 3 clicks are nested.

2. When following through the demonstrations, a bullet point indicates that
action is required, e.g.

. Now do this

Starting STATA for Windows

If you have followed the typical installation, you have to start STATA by clicking
on

Start > Programs > Stata > StataSE 8 as seen below.
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Accessaties
Ahead Nera

Mew OFffice Document:

©pen Office Document Hummingbird Connectivity 47,1
Microsoft Office Tools

RealOne Flayer

Microsoft Yisual C++ 6.0
SPSS For Windaws
Adobe Acrobat 5.0
Wwindows Update 2] Microsaft Excel

Set Program Access and Defaults

) IMicrasoft FrontPage
‘WinEdt
Micrasaft PowerPaint
WinZip Microsoft Word
Microsoft Producer

)
ahoo! Messenger SPSS Data Entry 3.0

Documents

Setkings

Search

Help

Run...

Shut Down....

Iﬁstart “ ] & oo Gy B (5 “ [ Inba - Micr..

AP 2N 1w

sessionl.do‘.‘l @Stata Capab,..| E0snaglt

This will initiate the STATA program.
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Special Fdition
http://vwu.stata.com
statalstata.com

I
Target: Command ‘windove
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A few things to know before starting to program in STATA is that

1. STATA is case-sensitive.

2. .isthe STATA prompt.

3. exit is the command to exit STATA which could either be typed in the

command window, or use the File menu.

Getting Help

STATA has an in built help facility. If you want to search for a particular function

(e.g. pie), just click

Help > Search...

This will open the following form

Choose which resources
you want STATA to
search from.

T

efs Data Graphics Statistics User Window | Help

(programming debugging) setti
et trace
et tracedepth

et traceexpand
et tracesep
et traceindent

|
¥ Search documentation and FADs

{~ Search net resournces

Cantents

Mews

Official Updates

51 and User-written Programs
Stata Web Site »

Ahout Stata

Type the keyword

here.
" Search 4l
K.epwords:
Ipie
Q. | Cancel |
5
Bach I Befreshl Search I Helpl Eontentslﬂhat's Hew| MNews
Eummandlseachpb
zearch for pie [nanual: [R] search) The result for ‘pie’

Keyuordz:  pie
Search:

Search of official belp files eg, 5Js, and STBs

[G] graph intro
[help graph_intral

[&] graph
[help graph)

[G] graph ple v v v e e e e e e e e e e e e e e e
[help graph_piel

lend of search]

(1) Mfticial help files, FAs, Exanples, SJs, and STBs

........... Introduction to the Graphicz nanual

....................... The graph connand

Pie charts

search.
<4
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If you know a particular keyword, such as‘d’, then you could use the STATA
command search under Help,

Stata command

Command:
|d

] | Cancel

to obtain

i Stata Yiewer [help d] x|
Back I Eefreshl Search I Helpl IEDntents What's Mew| MNews

Command: |he||:| d

e For the

help dezcribe desaribe condand
help dich d() date function

The underlined words are hypertexts links — clicking on them will link you to the
relevant page of the help information.

The STATA Console

b Frofs Dats Graphics Statiice User Window Fielo gl

This is the STATA
Console.

It contains

e amenu bar

a tool bar

a results window

a command window
a review window

a variables window

nnnnn
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The Menu bar

File Edit Prefs Data Graphics  Stakistics  User  Window  Help

The menu bar lists 9 pull down menus. When you click on one of these menus,
STATA displays a pull down menu listing the available commands. You will be
using all of these at some time during the course. Some users might prefer
typing the commands in the commands window, while most users will prefer
using the menu interface.

However, if you are running large batch programs, then it is advisable to use the
command window, together with a log file. We will see how to create a log file
later on during this session.

The Toolbar

=z d| & ¢ @88 3 88 o

The toolbar, located just below the menu bar, provides quick and easy access to
many frequently used facilities. When you put the mouse pointer on a given
tool, a description of that tool appears.

Open (use). Displays the Open File dialog box for an already saved
Source STATA code.

Save. Saves the current workspace.

@ =

Print results. Prints the results window.

Begin Log. Used to configure the log file.

0 |&

Start Viewer. Opens the STATA viewer window.

Bring Results Window to Front.

L]

! Bring Graph Window to Front. Only available when graph window is
open.
ﬁ Do-file Editor. Opens the STATA Do-file Editor.
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Data Editor. Opens the Data Editor.

Data Browser. Opens the Data Editor in browse mode.

ix]

Clear — more -- Condition. Only available when data is loaded.

Break. Will stop the computation that the STATA processor was doing.

Creating a log file

For
not

all serious work, a log file needs to be created to store the results. If this is
done, then all the results that are visible on the screen will disappear as

soon as they scroll off the top of the window.

You need to first check that the working directory is correct. This is done by
typing

pwd

in the command window. STATA results window

 pwd /
»Program Files~STATAB~data

The current directory will appear in the results window.

The Review Window contains \
the command history. q
d
Click on any line in the review puid
window and see it appear in edit
the command window. SIS
/ pund

I Stata Comm

pd
edit
browze
pid
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If the current directory is not correct, you can use the cd command to change it.
However, this requires that you type the correct directory structure.

&% stata,/SE 8.0

Another easy Way Would be to C“Ck on ’ﬁ Edit Prefs Data Graphics Statistics User Window Help
Open... Chrl+O — | =
2| 3 el (]
Save Chrl+5
H H Save A5, S+t 45
File > Log> Begin o
Filename. ..
Import » Close:
Expart 3 Suspend
Reesume:
Open Graph. ..
Save Graph.. Wigw, ..
Brint Graphi.. Translate. ..
Print Results...
Exit ale+F4
Begin Logging Stata Oukpukt ﬂﬂ
Save ir: Iadala j & &5 EO-
Choose the

directory where
you want the log
file to be saved.

Clicking on the
icon on the

toolbar will
generate the
same result.

File narme: In:n:ﬂ i j Save I

Save a3 type: IFormatted Log [ smel] =l Cancel |

7

The Result Window will output the directory structure where the log file will be
saved.

. log using "C:“Documents and Settings“cutajarb My Documentsz“Coursze notes~Introdu
ction S8TATA~data~logl.smcl"

log: G:\Documents and Settings“cutajarb My Documents“Course notessIntrodu
ction STATA~data~logl.smcl
log type: smcl
opened on: 2 May 2003, 10:31:14

The extension used by default by the log file is smel. This is STATA mark up
control language. This produced prettier output but it needs to be printed and
opened in STATA. You can also choose a plain text file by changing the
extension to *.log.

The logging can be stopped by clicking on the icon again. This will open the
following form.
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Stata Log Options

Select action for curent log; You can view a piece of
the log file, close the log
file completely or

% View snapshat of log file

" Close log file suspend until you re-
start the logging
" Suzpend log file process.

k. I Cancel

Suppose you decided to view a snapshot of the log file. The STATA viewer will
be opened showing all the commands and results that you obtained since you
start logging.

[ Stata Yiewer [view "C:" Documents and Settings'cutajarb® |
Back Befresh Search Helpl | Contentz | wWhat's Newl Hews

Command: |view "C:ADocuments and Settingshcutajarby DocumentshCourze notes'Introduction STA

log: Cz\Dooments and Settingsioutajarb\Hy DoomentsiCowrse notesiIntroduction STATAN
> atalogl.sncl
log tupe: smcl
opened on: 2 Hay N3, 10:34:51

When you close the log file, you can always view it by clicking on

File > Log> View

Type or browse for the directory File or LIRL:
and press OK.

Courze noteshntroduction STATANdataklogl . sme

The STATA viewer will open showing the log file.
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x
Back I Eefreshl Search Helpl IEuntentslﬂhat's Mew| HMNews

Command: |view "C:A\Documents and Settingzhcutajarbi My DocumentshCourge notesntroduction STATA!

log: CzDooments and Settingshvoutajarbily Dooments'Wourse notes\Introduction STATAW
» ataVlogl.sncl
log tupe: sncl
opened on: 2 Hoy 203, 10:34:51

. log cloze
log: Cz\Dooments and Settingshvoutajarbily Doouents\Lourse notes\ntroduction STATAW
» ata'logl.sncl
log tupe: sncl
cloged on: 2 Hay 203, 10-49-48

You can then print results from the viewer by clicking on

File > Print Viewer...
Practical Session 1a

1. Objective of this exercise

In this exercise you will retrieve an STATA data file and carry out a simple
analysis. (In a future exercise, you will create your own data files from scratch.)
This exercise also will allow you to become familiar with the main STATA
windows.

Starting STATA
From the Start menu in Windows, select
Start > Programs > Stata > StataSE 8

Suppose we wanted to load the cars data file. First of all, notice the extension
with the file cars.dta. This shows that the file contains STATA data.

Click on

File > Open

and choose cars.dta.

This will load a dataset containing speed and stopping distances for cars.
However, no variables appear. The Results Window displays the following
notification



. use "GC:xDocuments and Settingsscutajarb My Documents>Course notesIntroduction STAT

» Asdatascars.dta',. clear

indicating that the file has now been loaded into memory. i vari
Target: Command %indo

You can also notice that the Variables window contains the 3 4
variables that have been loaded: id, speed and dist. Z_peed
|zt

X

=
[

By clicking on the browse or edit button, we obtain the following:

il Stata Editor

Eleservel Bestore I Sort I L I *r I Hide I Qelete...l
idl11 = [l
id speed dist
2 2 4 10
3 3 ? 4
4 4 ? 22
5 5 8 16
6 6 2 10
? ? 10 18
8 8 10 26
2 2 10 34
10 10 11 1?7
11 11 11 28
12 12 12 14
13 13 12 20
14 14 12 24
15 15 12 28
16 16 13 26
17 17?7 13 34
18 18 13 34
19 19 13 46
20 20 14 26

By clicking on the variable name at the top of
the STATA Editor window, we can see the
details of the selected variable in the STATA
Variable Information.
format of the variable, and modify its name

and label as well.

You can choose the

The browse function is exactly
the same as the edit function,
except browsing the data does
not allow the dataset to be
changed. A spreadsheet display
of the data is produced.

Stata Yariabl

M ame:

k. Cancel




To finish, click on Preserve and close the window.

After changing the labels, you can see the script that STATA has written.

edit
- Preserve
- label var id "id of the capr'

lahel var speed “speed of car'
- label var di=st “distance"
PrESErUE

A simple analysis

To get STATA to calculate a frequency count for the variable speed, you need
to use the command:

-table speed

Alternatively, it is easier to use the Statistics menu in the menu bar. Hence,
click on

Statistics > Summaries, Tables & Tests > Table> Table of Summary
Statistics (Table)

to obtain
Main | by/itéin| Weights | Options |
Type the Fow wariable: Colurnn wariable:
variable that |speed |
you require . bl
the table of. [ ?uper row wariables: r ?uper it v ariatles
Statistics Percentils Yariable
1 INone j I 50 I
2 INDne j I EUﬁI
Press OK 3 [hone =]
4 INone j | EDﬁl
y EE=]

I\

[24R) \gK | cancel




- table speed

The first column of output gives the data points,
while the second column gives the frequency of
each data point respectively, i.e. there are 2 data
points having a value of 4, 2 data points having a
value of 7, etc.

2
2
1
1
3
2
4
4
4
3
2
3
4
3
5
1
1
4
1

To obtain a histogram showing the above table, type
- histogram speed
or click on

Graphics > Histogram
[ histogram - Histograms for continuous and categorical variables

For the tlme Main IB_\J ] iffin ] Weights] Maormal density] KDE ] Bar Iabels] iz ] X-Axis] Title ] Caption] Legend] Dverall]
H W ariable: {+ Continuous data Bar
belng’ type/v speed " Discrete data u 3 Gap between bars [percent]
;peed u.n%?r ol = Fil olor [Deraut =]
e variable - : =
- '— il af s Outline colar: | Default
name and Dutline width: | Default hd

u Lawwer limit of first bin

r-axis

ignore all the
other options. & Denciy
These will be ® Fssi
covered in " Frequency
more detail in a

later session.

ﬂ ﬂ = ak. Cancel

Subrnit

Click OK.

This will open a new console window showing the following graph:




[l Stata Graph |

Density

o
o

06

.04

02

There are options

' available how to

modify this graph,
but we will look at
- these later on.

Leaving STATA

To exit from STATA, click on

File > Exit

2. Creating your own STATA Data File Using the Data Editor

The data

In this exercise you will create a new data set, defining your own variables and
entering some data collected about 10 visiting students. The pieces of
information collected were:

1. Surname of student

2. Sex of student
3. Distance travelled to the University

Once you enter the data, you can get some summary statistics about the
distance travelled by the students.

The data to be used is given in the following table:



Surname Sex Distance
Brown 1 12
Smith 2 15
Robinson 1 93
Fligelstone 2 1
Green 1 12
Harris 2 6
Jenkins 1 25
Johnson 2 42
Frank 1 3
Stone 2 11

Defining the variables

Start STATA in the usual way by clicking on

Start > Programs > Stata > StataSE 8

Activate the Data Editor Window by clicking on the icon. Start typing
Brown in the 1% row, 1% column.

STATA will automatically name the 1% variable as var1. Double click on this
variable name to change this.

Change the name

of the variable
[ arne;

ISurname

Label:

I The format is %9s
Farmat: indicating that it is a
|3;93 «——1— | string variable.

k. Cancel

This allows you to enter the surnames as letters, rather than numbers. Press
OK to close this box. Fill in all the data.

Rename the second variable as Sex of type numeric, and the third variable as
Distance, also numeric.



I Stata Editor

_EE

x|
Ereservel Eestorel Sort I <4 I b5 I Hide I Qelete...l ﬂ
vardl4l = |
Surname Sex vard |
L Broun L 12 STATA defines
2 Smith 2 15 Y
3 Rohinson 1 93 missing data as
4 | Fligelstone 2 - -
5 Green 1 5
6 Harris 2 <
? Jenkins 1 -
8 Johnson 2
? Frank 1
10 Stone 2
I H s
il Stata Editor
P ervel Restore I Sort I %4 I F5 I Hide I Qelete...l
/ Surnamel1] = [T
Surname Sex Distance
Click on Preserve :w 1 12
before closing the 2 Snith 2 s
Editor. 3 Robinson 1 23
4 | Fligelstone 2 1
5 Green 1 12
6 | Y  Harris 2 3
P Jdenkins 1 25
] Johnson 2 42
7 Frank 1 3
The finished data / 10 Stone 2 1

set.

[

To make sure that all the variables are there and that they are in the format you
need them, we can use the ‘describe’ command. This can be abbreviated to
simply d, and it will provide basic information about the file and the variables.

ariable name

Distance

Eorted hy:
Mote:

3
170 (99 _9% of memory freed

storage
type

strll
hyte
huyte

#lls

display
format

#8_0g
#“8.0g

value
lahbel

variahle label

datazet haz changed zince last zaved




The command can be also accomplished by the pull down menu system

Data > Describe Data > Describe Variables in Memory

¥ Stata/SE 8.0

de Edt Prefs | Dats
_I Jesc

(e &)= -
Data edit
_ felte) y Describe data contents (cadebook)
Data browser (read-only editor) et yerEyes
ZTREEEESNE  Create or change variables i

Sork
Combine datasets

3
3
3
Labels & notes 2
3
3
3

aphics  Statistics  User  Window

List data
Compactly list variable names

Summary skatistics

{1 unigu

Wariable utilities

describ
eseribe Matrices

Other utilities

Alternatively, you can obtain other type of descriptions, from the same pull down
menu system.

If you click on
Data > Describe Data > List Data

you would obtain the following Window.

Leave blank to obtain il list - List values of variables

a list of all the kM ain | I:u_l,la"ih"inl Dptiunsl Summar_l,ll .ﬁ.dvancedl

variables.
\ Variablyf’@-’e empty for all vwanables)

— Colurnb widths
& Defaul
£~ Compresz width of columnz in both table and dizplay formats

" Use display format of each varable

Leave empty to select all
the cases and to leave I I 83: kinimumn abbreviation of variable names

the file unsplit.
P 1 I 103: Truncate string wariables to M characters

[~ Suppress listing of obzervation numbers

Press OK

ﬂ ﬂ T 0K Cancel 5 ubrnit

STATA produces the following list. It has increased a new column, _delete. At
the moment, all values under this column are 1; indicating that all rows will be
considered and none are deleted.



. list, separatorih?

Surname Sex Distance _delete

1 1
2 1
1 1
2 1
1 1
2 1
1 1
2 1
1 1
2 1

Saving the Data

To save the new data file created, click on

File>>Save As... from the Main Menu bar.

Save Stata Data File ﬂﬂ

Select a name for your Savein: | data - - EeE-

file e.g. distance cars.dta
[Eexample.dta

Click on the Save
button.

File name: I X v| t Save I
Save a type: IStata D ata [*.dka) j Cancel |

g

If you have a floppy disk with you, put it into the ‘a:’ drive now. It is a good idea
to save your work to a floppy disk rather than the hard disk of the computer for
two reasons:

" You are not tied to using the same machine each time.

" Your file may be erased from the hard disk.

STATA will display the result of the Save file operation in the Results Window.




. save "C:x\Documents and Settingsscutajarb“My Documents“Coursze notes“Introducti
> on STATANdatasdistance.dta®

file C:“Documents and Settings‘cutajarbMy Documents“Coursze notes~Introduction
> STATAsdatasdistance.dta saved

Some descriptive statistics

To find out the average distance the students travelled, click on

Statistics » Summaries, Tables & Tests > Summary Statistics> Summary

Statistics
x4
= i Main | by/itsin | weights |
Target: Command ‘indow Wariables: [leave empty for all varables)
g:;name = > | Distance
Digtance / Examples: [T all wariables starting with !
_delete nypz-abc all wanables between wyz and abc
Options
{* Standard dizplay
(" Dizplay additional statistics
4 - (" Mo dizplay; just calculate mean

[ Use varable's dizplay farmat

53: Separatar line every N variables [zet O far none]

Choose and click on the

variable from the ﬂ ﬂ ok Cancel Subrit

Variables window.

This should give the following table.

. summarize Distance

Variable Std. Dew.

Distance 27 .64457

Note that STATA displayed some other summary statistics, such as the
standard deviation, the number of observations, and the minimum and
maximum values.

You can obtain additional statistics by choosing the ‘Display additional statistics’
option.



. summari=e Distance, detail

Diztance

Percentiles Smallest

i

3

[ Ohs

11 Sum of ligt.

1
1
2
6

12

Mean

Largest Std. Dewv.

15

25 Uariance
42 Skewness
23 Kurtosis

The variance is now given to be 764.222.

Finally obtain a histogram of Distance by clicking on

Graphics > Histogram

10
10

22
27 64457

7642222
1.896242
5.495847

[ histogram - Histograms for continuous and categorical variables

Main IBy ] if/in ] W'ewghts] Morrmal denswty] KDE I Bar Iabels] s I X—Ast] Title: ] Captinnl Legend] Dvelalll

Yariable

' Continuous data

' —
Choose DIStance Distance " Dizcrete data

|| 3 Murmber of bins
| | ‘width of binz

| | Laweer limit of first bin

-aniz

¥ Density

Press OK

" Fraction
" Frequency

Bar

r 3 Gap between bars [percent]

Fill color: |Defaul =
Outing color: | Default =

Outling width: | Default

-

il
Target: Yariable
Surmarne
Sex
Distance
\ _delete
g g L _delete
= x|
Lo
o
=]
oy
=
Lo
za ]
o
[
[
(]
5 4
L)
= 4
=
=

20

40 B0 an
Distance
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Clearing the memory

To remove the variables from memory, you could use the command clear.

C100.0 of memory free?

Forted hy:

Reading a Raw Data File

In the previous exercise we retrieved and created STATA data files. These are
special files that only STATA can read or create. In many instances you may
want STATA to read a raw data file that has been created by using a word
processor, spreadsheet or database — or files that are in ASCII (Text) format.

‘Text’ files can be arranged in several ways. For instance, if you have only
collected information for a few variables for each person, the data could be
written to the data file so that a new line is started for each person. You could
also decide that each variable will occupy the same column in the data file. This
is often known as fixed format.

2 [3]4]5 11 | 12 | Column numbers

Variable names

age S

Filename:
example.dat

aln|w|n[s S| o

NN |wlw NS S

(CIENITNY BRN N P

g~ [wN(=|a ]|~
NWINIAIN
AN O|IN

This data file above is in fixed format. Each variable is in its own column(s) and
together they take up a total of 12 columns. It is normal to go on to the next line
after column 80, which is the width of most screens. Once again, each variable
must be in the same location for each case. So if the variable V101 is in
column 5 on the second record of data for person 1, then it must also be in that
location for the next and subsequent cases.

With 300 variables we could have 6 records to an individual, for e.g.

CASE1.1 . V001, V002 - - - = === == === o oo mmmmmeeee oo e V80, V81
CASE1.2 . V82, ------=-- VA0T = mmmm e
CASET.3 - - mmm o e mm e ieee e
01T = s

073 =5
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CASEN.6 - == === === mm e V300

CASE2.1 . V001, V002
CASE2.2 . V82,------
...etc.

oM~

A note about variable names in STATA:

Variable names are unique in any one file.
Variable names can be up to 32 characters long.
Variable names start with a letter or an underscore.
Variable names must contain no spaces.

Each of the variables in your data must be given a name. When deciding
upon a name it is a good idea to follow some conventions...

Suppose we want to open the file example.dat. If you click on

File > Open

The Open File dialogue
box appears for you to
select the ASCIl data
file you wish to read into
STATA.

Raw data is usually in a
file with either .txt or
.dat as the suffix.
Change the type of file
STATA is looking for
from All Files (*.*)

Laok, ir: Iadala j - £ ER-
| Hdcars.dta
=] cars.bxt
[@distance.dta
EX&MPLE.DAT
[@example dta
log1,smel
My Documents

File narme: IEX&MF’LE.D.&T j Open |

|| Files of ype: [ Files () =] Cancel |

B

. use "C:sDocuments and Settings“cutajarb My Documents“Course notes“Introduction
» STATA~data~EXAMPLE.DAT", clear

(610 ;

This generated an error as the file is not
in a format that STATA recognizes.
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The correct way of doing it is to click on
File > Import > ASCII data created by a spreadsheet

_ ﬂ

ASCI dataszet filename:

/Q:KDacuments and SettingzhoutajarbhMy DocumentshCourse nate Browse...

Select the file M ew variable names: [optional]
example.dat by clicking |
on Browse. ;

O ptionz

[ Stare varables as doubles

[+ Specify value delimiter:

/ " Comma

Choose the delimiter to " Tah
be a blank space - l—

| Replace data in memary

Click OK ﬂ ﬂ oK Canicel S ubmit

- insheet wusing "C:“Documents and Settings“cutajarb My Documents“Course notes>Int
[ roduction STATANdata“~EXAMPLE._DAT" . delimitep{" ')
(6 varzs, 5 ohs>

You see that STATA made use of the insheet command. This command is

very useful in reading in data from a spreadsheet or database program where
the data values are delimited.

Another way of doing this is to tell STATA where the columns for each variable

are. By doing this, we can define the variable names while loading the data,
rather than afterwards.

Click on
File > Import > ASCII data in fixed format
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ol X

Main | itsin |

" Use dictionarn file:

Note that str is
needed in front of

Specify the columns. | Q

{* Specifications:

sex. |i|:| 1-1 age 3-4 str gex B-6 varl 8-8 war2 1010 war2 1212

Examples

rate 1-4 speed B-7 acc 3-11
2 lines 1: id 1-6 =tr name 7-36 2 age 1-2 zex 4

A5CI datazet filename: [required]
|E:'xDD|:uments and Settingzhcutajarbi My DocumentshCourse oty Browse. .

| Replace data in memary

ﬂ ﬂ OF. | Cancel | Submit

You can then view the variables loaded in memory by using the list command or
the pull down menu.

. infix id 1-1 age 3-4 str sex 6-6 vard 8-8 var2 10-10 var3d 12-12 uwsing "C:“Docu
[+ entsz and Settings:cutajarb“My Documents-Coursze notes:Introduction STATA~data“EX
> AMPLE.DAT"

5 ohszervations read)>

.1

varl vapr? var3

Adding Labels

After STATA has read the data for each of the variables into the Data Editor
Window, labels can be defined to give meaningful descriptions for them.
Obviously, a variable named sex does not really need a label, but one named
var1 clearly does so that anyone reading the STATA output can understand
what information is stored as var1.

There are two kinds of label that can be applied to each variable, variable labels
and value (or character) labels. Variable labels expand on the variable name -
they tell you what question was asked, and value labels tell you what the
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numerical code given to each response means. So “Sex of respondent” would
be the variable label for sex and “Male” and “Female” would be the value labels
given to the codes M and F respectively.

Stata Yariable Infor

To label the variables, double click on
the variable name var1 in the column

heading of the Data Editor.

A

Variable Label for var1 can be typed

into the cell in the Label column.

I arne;

Ivar'l

Label:
ISmnking iz a danger to the people around pou

Farmat:
|%6.09

0k, Cancel

Initially, a variable will have no value labels attached to it. To add Value Labels,

click

Data > Labels & Notes > Define Value Label

The following window will open

Define value labels x|

Click on Define

Define label names Walue labelz
Define. Drop.. A | Medfy. |
Cloze |
x| You can give this labeling a

Define new label

Label name

name so that it can be used

/ with more than 1 variable.

I.-’-‘-.gree_Disagree

K |

Cancel

Ly

\

Press OK
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Type the 1% label and press
OK

Define value labels

Define label names

Agree Dizagres

Define. Dirop...

\

x
Walue
|1
Text
IStru:ungI_l,l Agree
aF. | Cancel
X
Yalue labelz

1 Strongly Agree

Add. |

Medfy. |

Cloze |

Add option is now

available. Add the
other 4 value labels.

Each value is typed into the Value box, followed by its label in the Value Label
box. Finally, the Add button is clicked.
highlighting the label in the Value Labels box, and clicking on Modify.

Any errors can be corrected by

When you have finished adding the Value Labels, the windows would look like

Define value labels

this.

Define label names

Agree Dizagres

Define.

Yalue labelz

X

Ly I S R A

Strongly Agree
Agree

Meither Agree nor Disagree

Disagree
Strongly Disagrees

Dirop... | |

add. |

Close

Medfy. |/

Cloze

L
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If you know list the data for this variable, you will still obtain the same numbers,
rather than the new values.

list varl,. separatorisS>»

This is because we have not attached the labels to the variable. To do so, click
on

Data > Labels & Notes > Assign Value Label to Variable

= B x|

W ariable;
Choose the label |varl
and attach it to
var1. (¥ Aftach value label:
OK

[ Prevent display formats from being widened

(" Remove exiztrgyalue [abel

[2/fR)

ok | cancel | Submit |

Listing the variable will now output the value labels instead of the corresponding
numeric values.

. list varl, separator<S>

Dizagree

Agree

Meither Agree nor Dizagree
Agree

Strongly Agree
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Practical Session 1b

Create a log file for this practical session.

In this exercise you will be using STATA for Windows to read a raw data file and
define variable labels and value labels for each variable.

You will be using a very small set of data taken form the 1987 Social Attitude
Survey. This survey is carried out annually by The Social and Community
Planning Research Unit. We have extracted the responses of 25 people to five
questions, from the survey. The data from these questions will be put into five
STATA variables. The following is a ‘coding sheet’ which shows details about
the questions.

Variable Variable Columns | Value labels Codes
label name in data file
Q1 | Respondent’s sex | RSEX 2 Male 1
Female 2
Q2 | Respondent’s age | RAGE 4-5 (Code is age in years)
No response 99
Q3 | Which income | SRINC 6 High income 1
group would you Middle income 2
place yourself? Low income 3
No response 9
Q4 | How well are you | HINCDIFF 7 Very well 1
managing on your Quite well 2
income? Not very well 3
Not at all well 4
Don’t know 8
No response 9
Q5 | Respondent’s RRGCLASS 11 Professional 1
social class Intermediate 2
Skilled 3
Semi-skilled 4
Unskilled 5
Unable to classify 8
Not applicable 0

Using the coding sheet, get STATA to read the five variables in the raw data file,
‘sample.dat’.

Add variable labels, value labels and missing values for all the variables. Obtain
a frequency distribution for all the variables.

Check that all your variables have been labeled correctly and have missing
values by looking through the output. Print the output.
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Save your data file to a *.dta (or STATA) format.
2. Reading more than 1 record of data per case

The small ASCIlI data set we read into STATA in this session has been
rearranged so that the data for each case is over 2 lines. The new ASCII data

file is in D:\Spsswin\Data\Example2.dat, and is shown below:

Line 1: Line 2:

1 ]2]3]4 5] s Column numbers 1 2 |3 4 |5
id age sex Variable names var1 var2 var3
1 2 2 M 1 4 2 |1
2 4 0 F Filename: 2 2 3|1
3 2 7 M Example2.dat 3 3 3|2
4 3 5 M 4 2 2|4
5 2 4 F 5 1 2|2

Remember that you have to tell STATA which variables are in line 1 and which

are in line 2.

il infix - Import ASC m x|

Main |itsin |

™ Usze dictionary file:

I Browse, .. |

% Specifications:
|2 linez 1:id 1-1 age 3-4 str zex 6-6 2:varl 1-1 var? 33 vard 4-5

Examples

rate 1-4 zpeed B-7 acc 3-11
2 lines 1: id 1-6 ztr name 7-36 2 age 1-2 zex 4

ASCI datazet filename: [required]
IE:'\D::u:uments and SettingztcutajarbybMy Documents“Course note. Browse. . |

[~ Replace data in memaorny

(2R ok | Cancel | Submi

Obtain a frequency distribution for the variables, as well as some summary

statistics.

Create a new variable, gender, which is numeric. Create value labels (‘M’ and

‘F’) for this variable.

Obtain a histogram for each variable.
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